「ファイル」→「レコードのエクスポート」で行うエクスポート作業を
1ボタンで出来るようにする手順のご案内です。

(※この手順では、頑張れ店長/店舗アップに保持しているデータをそのまま出します。
 ヘッダ行を固定したり、保持している情報から別の値を出す等、
 検索結果からそのままのデータでは出せないデータの出力は有償対応になりますので、

 ご希望の場合はカスタマイズご依頼フォームからお問い合わせ下さい。

1.頑張れ店長/店舗アップのデータを出力したい画面を表示し、
 「表示」→「レイアウトモード」で切り替えます。

2.適当なボタンをコピーし、出力ボタンを置きたい場所に貼り付けます。

3.貼り付けたボタンを右クリック→ボタン設定を選択します。

4.ボタン設定画面が出てくるので、スクリプト実行部分を「単一ステップ」に切り替えます。
 (この部分はFileMakerのバージョンにより異なる場合があります。)

5.ボタン処理画面が出てくるので、画面右側から「レコードのエクスポート」をダブルクリックします。

6.歯車マークを押し、エクスポート順の指定の「指定」ボタンを押します。

7.レコードのエクスポート順画面が出てくるので、
 画面左側から出力したい項目をダブルクリックし、フィールドのエクスポート順枠内に入れていきます。
 (画像では受注番号、注文日、注文時間が出力されます。)

8.オプション枠内、出力ファイルの文字セットの部分を「日本語(Shift-JIS)」に変更し、OKで全て閉じます。

9.ボタンのラベルをお好みで変更し、
 「表示」→「ブラウズモード」で切り替えます。

修正は以上です。

☆データ出力時の小技☆
ボタンを押して保存場所やファイル名を選択するタイプの出力ボタンの場合、
ファイルの種類を「Mergeファイル」、ファイル名に.csvを付けて保存して頂くと、
項目名の付いたデータを出力することが出来ます。

その他のFAQ

FAQ

ftpユーザーID確認方法

    FFFTPを立ち上げます。 普段弊社とやり取りを行っているホスト名にカーソルを合わせ、一右側にある「設定変更」をクリックします。 ※下記画像のホスト名は、「新nbs」ですが、「店舗アップ♪」、

続きを読む